DeprecationLevel

Common
JVM
JS
Native
1.0
enum class DeprecationLevel
(Common source) (Native source)

Possible levels of a deprecation. The level specifies how the deprecated element usages are reported in code.

See Also

Deprecated

Enum Values

Common
JVM
JS
Native
1.0

WARNING

Usage of the deprecated element will be reported as a warning.

Common
JVM
JS
Native
1.0

ERROR

Usage of the deprecated element will be reported as an error.

Common
JVM
JS
Native
1.0

HIDDEN

Deprecated element will not be accessible from code.

Extension Functions

Common
JVM
JS
Native
1.0

coerceAtLeast

Ensures that this value is not less than the specified minimumValue.

fun <T : Comparable<T>> T.coerceAtLeast(minimumValue: T): T
Common
JVM
JS
Native
1.0

coerceAtMost

Ensures that this value is not greater than the specified maximumValue.

fun <T : Comparable<T>> T.coerceAtMost(maximumValue: T): T
Common
JVM
JS
Native
1.0

coerceIn

Ensures that this value lies in the specified range minimumValue..maximumValue.

fun <T : Comparable<T>> T.coerceIn(
    minimumValue: T?,
    maximumValue: T?
): T

Ensures that this value lies in the specified range.

fun <T : Comparable<T>> T.coerceIn(
    range: ClosedFloatingPointRange<T>
): T
fun <T : Comparable<T>> T.coerceIn(range: ClosedRange<T>): T
Common
JVM
JS
Native
1.0

rangeTo

Creates a range from this Comparable value to the specified that value.

operator fun <T : Comparable<T>> T.rangeTo(
    that: T
): ClosedRange<T>

Inheritors

Common
JVM
JS
Native
1.0

ERROR

Usage of the deprecated element will be reported as an error.

Common
JVM
JS
Native
1.0

HIDDEN

Deprecated element will not be accessible from code.

Common
JVM
JS
Native
1.0

WARNING

Usage of the deprecated element will be reported as a warning.